Ergebnis 1 bis 3 von 3

  1. Beiträge
    3
    Registriert seit
    03.06.2007
    Neuer Benutzer

    Webserver Moved Permanently Response

    Hallo,
    ich bin mir nicht ganz sicher ob ich hier richtig bin, doch ich versuchs einfach (Bin für Tipps wo ich diese Frage besser stellen kann offen).

    Ich sende mit einem Script eine Anfrage an einen WebServer http://Username:Passwort@domain.tld/Verzeichnis Der WebServer leitet mich danach direkt mit einer 301 Response auf http://domain.tld/Verzeichnis weiter. Dieses Verhalten ist natürlich nicht erwünscht, da dass im /Verzeichnis liegende Script dann keine Zugangsdaten bekommt. Der Request wird über JQuery ajax abgesendet, als ich eine HTTP Basic Authentifizierung über Apache (.htaccess) hatte hat dies auch fast funktioniert. Ich musste mir dies aber nun in PHP selber basteln und nun kommt dieser Müll.

    Ist das verhalten normal? Muss ich bei einer selbst geschriebenen Authentifizierung etwas beachten?

    Das PHP Script mit der Authentifizierung weicht an einem (benötigten) Punkt vom Standard ab. Es überprüft ob im HTTPHeader Zugangsdaten enthalten sind, falls nicht sendet es einen Authorization Required zurück (401). Falls Zugangsdaten enthalten sind überprüft es diese und gibt entweder ok oder (Achtung Abweichung vom Standard) einen 400 Fehler zurück.

    VG
    Marius

  2. Registrieren, damit diese Werbung verschwindet.

  3. Beiträge
    3
    Registriert seit
    03.06.2007
    Neuer Benutzer

    AW: Webserver Moved Permanently Response

    Das Problem ist nun gelöst, es lag daran, dass die URL kein abschließendes / beinhaltete.
    Ich wurde also bei meinem Request http://user:pass@domain.tld/Verzeichnisauf http://domain.tld/Verzeichnis/ weitergeleitet, dieser kleine Unterschied ist mir erst nach einer Debugging Zeit aufgefallen.... Jetzt gehts.

    VG
    Marius


  4. Beiträge
    3.624
    Registriert seit
    10.06.2004
    Ort
    Rosbach bei Frankfurt

    Optimate-Server

    Gepruefter Provider

    AW: Webserver Moved Permanently Response

    Die Anweisung user:pass@domain.tld kann nur FireFox.
    Bei Google Chrome, Internet Explorer etc gehts nicht :)
    | Homepage: http://www.optimate-server.de | Email: info@optimate-server.de |
    | Telefon: 06003 / 9344144 | Telefax: 06003 / 9344143 | ICQ: 87243150 |
    | Housing | Rootserver | Gameserver | Domains | Webspace | Voiceserver |

Ähnliche Themen

  1. Apache lange response Zeit / Antwortszeit
    Von Bunnyps im Forum Webserver (Software): Linux, Unix, etc.
    Antworten: 4
    Letzter Beitrag: 25.08.2008, 14:42
  2. Zabbix: Response-Zeit als Graph auswerten
    Von G.Schuster im Forum Script Serverseitig
    Antworten: 0
    Letzter Beitrag: 17.06.2007, 21:05
  3. Response Time, 20" LCD Multi-media Display?
    Von buster im Forum Smalltalk
    Antworten: 1
    Letzter Beitrag: 06.08.2004, 13:39
  4. Antworten: 7
    Letzter Beitrag: 04.08.2004, 17:11
  5. Logout - Server response 401
    Von Paintball im Forum Script Serverseitig
    Antworten: 3
    Letzter Beitrag: 26.07.2001, 22:51

Content Relevant URLs by vBSEO 3.6.0