Ergebnis 1 bis 3 von 3

  1. Beiträge
    432
    Registriert seit
    07.10.2001
    Erfahrener Benutzer

    Apache 2.0.28 + PHP 4.1

    Hallo,


    ich habe gerade versucht Apache 2.0.28
    mit PHP 4.1 unter Suse Linux zu kompilieren.
    Leider klappt das nicht : PHP sagt beim
    Kompilieren : sapi_apache.so error.

    Sicherlich sind einige Schnittstellen
    in Apache 2.0 etwas anders als in 1.3.

    Wie bekomme ich Apache 2.0.xx + PHP 4.1
    zum Laufen?

    Leider habe ich noch kein Tutorial
    gefunden (Google)...

    Danke!

    Telefoni

  2. Registrieren, damit diese Werbung verschwindet.

  3. Beiträge
    957
    Registriert seit
    11.06.2001
    Vielschreiber

    RE: Apache 2.0.28 + PHP 4.1

    Hi,

    > Wie bekomme ich Apache 2.0.xx + PHP 4.1
    > zum Laufen?


    installiere mal den apache2 ohne php sonden mit dem DSO Support und füge das bei php
    --with-apxs=/usr/local/apache2/bin/apxs
    hinzu ...


    Tschüss
    Alex


  4. Beiträge
    432
    Registriert seit
    07.10.2001
    Erfahrener Benutzer

    RE: Apache 2.0.28 + PHP 4.1

    Hi,

    ich habe Apache 2 mit
    --enable-so kompiliert.

    PHP 4.1 habe ich mit :
    --with-apxs2=/path/to/apxs2

    kompiliert.

    Ich habe auch in httpd.conf

    <Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>

    gesetzt. Mehr bräuchte man
    angeblich nicht (Kein
    AddModule / LoadModule / AddType).

    Neukompilierte
    libphp4.so ist in das Apache2/lib-
    Verzeichnis kopiert.

    Apache 2 startet, doch beim
    Aufruf eines PHP-Skripts steht im
    Error.log : an unknown filter was
    not added: PHP

    In anderen Postings hiess es, Apache2
    wüsste durch die Benennung "PHP" in
    SetOutputfilter / SetInput-Filter schon
    was er zu tun habe... anscheinend nicht.

    Meiner Meinung anch fehlt der logische
    Schritt woher Apache2 weiss, welche
    DSO denn mit "PHP" gemeint ist...

    Gruß

    Telefoni

Ähnliche Themen

  1. Apache: Dateien groß und CSS Problem?
    Von Kekz im Forum Script Serverseitig
    Antworten: 1
    Letzter Beitrag: 02.02.2002, 13:43
  2. Apache 2.0 mit PHP 4.1 geht nicht
    Von telefoni im Forum Webserver (Software): Linux, Unix, etc.
    Antworten: 1
    Letzter Beitrag: 28.12.2001, 00:40
  3. PHP neu kompilieren (LAMP vorhanden)
    Von MAPE im Forum Webserver (Software): Linux, Unix, etc.
    Antworten: 28
    Letzter Beitrag: 02.08.2001, 22:41
  4. libphp4.so - Wie neu für Apache kompilieren?!?
    Von MAPE im Forum Webserver (Software): Linux, Unix, etc.
    Antworten: 2
    Letzter Beitrag: 25.07.2001, 21:10
  5. PHP Apache Version
    Von kevin im Forum Script Serverseitig
    Antworten: 2
    Letzter Beitrag: 21.04.2001, 23:17

Content Relevant URLs by vBSEO 3.6.0