Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 24

  1. Beiträge
    1.616
    Registriert seit
    10.03.2004
    Ort
    Landshut
    Alter
    40

    SPIEGLHOF media GmbH

    Gepruefter Provider

    AW: Probleme mit mod_proxy

    Nun mach mal nicht so geheimnisvoll, sondern nenn mal konkrete Domains, IPs und die exakte Konfiguration. Dann kann man auch vernünftig helfen.

    Insbesondere das hier irritiert:
    Wenn ich jedoch den Dateinamen definiere, den er aufrufen soll, dann gehts nicht.
    Willst Du nun Proxy machen (also ganze Namensräume [=Domains] extern einbeziehen) oder die Requests auch noch verändern ("Dateinamen definiere")? Dann brauchst Du neben mod_proxy auch mod_rewrite und nicht Deine Proxy-Direktiven, sondern RewriteRules mit dem integrierten Proxy-Krempel, z.B. so:

    RewriteRule /index.html http://woanders.net/blubb.php [P]


    Vielleicht habe ich Dich aber auch nur missverstanden ;-)
    SPIEGLHOF media GmbH // info @ spieglhof-media . de
    managed Server, Systemadministration, Webapplikationen, Domains, Webspace, SSL

  2. Registrieren, damit diese Werbung verschwindet.

  3. Beiträge
    1.054
    Registriert seit
    29.08.2002
    Ort
    Frankfurt/Main
    Foren-Guru

    AW: Probleme mit mod_proxy

    ok dann adde mal bitte folgendes in die .conf

    LogLevel Info bzw LogLevel Debug

    und paste dann die logs am besten ins

    http://cpp.sourceforge.net/


  4. Beiträge
    2.876
    Registriert seit
    01.12.2003
    Ort
    Düren

    XaraNet

    Provider

    AW: Probleme mit mod_proxy

    ich meine mit Dateinamen definieren lediglich:

    web1.xaranet.de => geht (zeigt die index-datei von foo.example.com an)
    web1.xaranet.de/index.php => gibt Fehler 500
    web1.xaranet.de/irgendeine_sonstige_existierende_datei.php => ebenfalls Fehler 500
    SMS und Faxe online versenden mit https://www.fullsms.de


  5. Beiträge
    1.616
    Registriert seit
    10.03.2004
    Ort
    Landshut
    Alter
    40

    SPIEGLHOF media GmbH

    Gepruefter Provider

    AW: Probleme mit mod_proxy

    Fehler 500 hat normalerweise nichts mit dem Proxy zu tun. "Illegal (Proxy) Request" hat normalerweise ne andere Hausnummer (gerade nicht im Kopf).

    Deine externen PHP-Seiten funktionieren ohne Proxy einwandfrei?
    Hast Du fastcgi oder suphp laufen?
    => für mich sieht das mehr nach einem PHP-Problem aus, muss aber nicht sein

    Von welchem Server stammt die Signatur der Fehlermeldung? Vom externen oder vom Proxy?


    Du weisst ja, die Kristallkugel ist schon wieder in der Inspektion... :-)

    Also: Entweder konkrete Daten liefern oder (allein) weiter im Dunkeln tappen...
    SPIEGLHOF media GmbH // info @ spieglhof-media . de
    managed Server, Systemadministration, Webapplikationen, Domains, Webspace, SSL


  6. Beiträge
    236
    Registriert seit
    23.06.2004
    Ort
    Frankfurt a. M. / Hauzenberg bei Passau
    Alter
    31
    Erfahrener Benutzer

    AW: Probleme mit mod_proxy

    Zitat Zitat von nocare
    du willst mir aber jetzt nicht erzählen das das nicht geht *rofl*
    Habe ich angekündigt, dir das zu erzählen? Sicher nicht.

    Schiermi

  7. nocare

    AW: Probleme mit mod_proxy

    Zitat Zitat von schiermi
    Habe ich angekündigt, dir das zu erzählen? Sicher nicht.

    Schiermi
    och gottchen....


  8. Beiträge
    236
    Registriert seit
    23.06.2004
    Ort
    Frankfurt a. M. / Hauzenberg bei Passau
    Alter
    31
    Erfahrener Benutzer

    AW: Probleme mit mod_proxy

    @TimoDreger - war gestern schon spät - versuche mal

    ProxyRequests Off
    ProxyPass / http://foo.example.com/
    ProxyPassReverse / http://foo.example.com/

    ohne / entfernt apache beim eingehenden Request den Slash - fügt ihn aber im Proxy-Prozess nicht mehr an, damit entsteht http://foo.example.comirgendeinedatei.php was folglich nicht mehr auflös- / bearbeitbar ist - und es kommt zum 500er.

    Schiermi
    Geändert von schiermi (25.11.2005 um 16:54 Uhr)


  9. Beiträge
    2.876
    Registriert seit
    01.12.2003
    Ort
    Düren

    XaraNet

    Provider

    AW: Probleme mit mod_proxy

    Zitat Zitat von schiermi
    @TimoDreger - war gestern schon spät - versuche mal

    ProxyRequests Off
    ProxyPass / http://foo.example.com/
    ProxyPassReverse / http://foo.example.com/

    ohne / entfernt apache beim eingehenden Request den Slash - fügt ihn aber im Proxy-Prozess nicht mehr an, damit entsteht http://foo.example.comirgendeinedatei.php was folglich nicht mehr auflös- / bearbeitbar ist - und es kommt zum 500er.

    Schiermi

    Wunderbar, vielen Dank - das wars :-)
    SMS und Faxe online versenden mit https://www.fullsms.de


  10. Beiträge
    1.616
    Registriert seit
    10.03.2004
    Ort
    Landshut
    Alter
    40

    SPIEGLHOF media GmbH

    Gepruefter Provider

    AW: Probleme mit mod_proxy

    LOL, Da waren wohl einige -- mich eingeschlossen -- ziemlich blind am Start ;-)
    SPIEGLHOF media GmbH // info @ spieglhof-media . de
    managed Server, Systemadministration, Webapplikationen, Domains, Webspace, SSL


  11. Beiträge
    2.876
    Registriert seit
    01.12.2003
    Ort
    Düren

    XaraNet

    Provider

    AW: Probleme mit mod_proxy

    So,

    wie gesagt das hat alles super funktioniert.

    Ich hab nun jedoch ein kleines weiteres Problem.

    Ich habe derzeit die Config: HTTP 'proxyt' auf HTTPS:

    ProxyRequests Off
    ProxyPass / https://foo.example.com/
    ProxyPassReverse / https://foo.example.com/
    Wenn ich jedoch HTTPS 'proxyt' auf HTTPS machen möchte, dann bekomm ich ein 403 Forbidden von meinem apache-ssl zurückgegeben.

    Das ganze wie gesagt über das apache-ssl paket von debian sarge.
    Unter apache-ssl funktioniert aber ein HTTPS auf HTTP ohne Probleme.

    Woran kann das liegen - hat jemand eine Idee?

    Vielen Dank und Gruß

    Timo
    SMS und Faxe online versenden mit https://www.fullsms.de

Seite 2 von 3 ErsteErste 123 LetzteLetzte

Ähnliche Themen

  1. Probleme mit SSL!?
    Von 7lifes im Forum 3.x Allgemein
    Antworten: 2
    Letzter Beitrag: 19.07.2005, 16:01
  2. SSL-Probleme
    Von Gast im Forum Confixx Classic 1.x
    Antworten: 0
    Letzter Beitrag: 05.06.2002, 14:02
  3. Probleme mit FTP
    Von Gast im Forum Confixx Classic 1.x
    Antworten: 1
    Letzter Beitrag: 10.03.2002, 17:04
  4. Probleme mit SSI
    Von Gast im Forum Confixx Classic 1.x
    Antworten: 5
    Letzter Beitrag: 06.12.2001, 23:16
  5. Probleme mit shg-net.de?
    Von Gast im Forum Webhosting Allgemein
    Antworten: 0
    Letzter Beitrag: 08.03.2000, 23:24

Content Relevant URLs by vBSEO 3.6.0